123
456
789
123
456
版面風格

(共 12 個樣板佈景)

XOOPS hc - xoops | 2017-03-10 | 人氣:206

XOOPS升級2.5.8.X的注意事項

  • XOOPS2.5.7之前的版本無法在PHP7上面跑,因此ubuntu若要升級到16.04前務必將XOOPS先升級到2.5.8.X
  • 因為XOOPS從2.5.8之後核心正式支援IPv6,若server和client端都是IPv6,升級會死翹翹
  • 解決的方式是找到session資料表,將 sess_ip 從varchar(15)改成varchar(45),改完再登入
  • 上面的步驟絕對不要先登入才改,如果已經改了就先登出再登入,不重登硬傳升級檔案會完全無法登入(弄死的話把舊版傳一份上去就會活回來了,清空session應該也能解)
  • server和client端只要有一端不是IPv6就沒有上面的問題
  • 接下來用一般方式升級即可
  • 升級2.5.8.X之後第一次去後台升級system模組時會找不到東西可以按,因此得事先進入後台的模組管理頁面等著點升級
  • 忘記的話就在網址列上貼 [網址]/modules/system/admin.php?fct=modulesadmin&op=update&module=system  直接進更新頁面